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Lorman’s New Approach to Continuing Education

ALL-ACCESS PASS

The All-Access Pass grants you UNLIMITED access
to Lorman's ever-growing library of training resources:

M Unlimited Live Webinars - 120 live webinars added every month

M Unlimited OnDemand and MP3 Downloads - Over 1,500 courses available
M Videos - More than 1300 available

M Slide Decks - More than 2300 available

M White Papers

M Reports

M Articles

|

... and much more!

Join the thousands of other pass-holders that have already trusted us
for their professional development by choosing the All-Access Pass.

Get Your All-Access Pass Today!

SAVE 20%

Learn more: www.lorman.com/pass/?s=special20

Use Discount Code Q7014393 and Priority Code 18536 to receive the 20% AAP discount.

*Discount cannot be combined with any other discounts.



Navigating and Customizing Your Workspace

The first step to Taking Control of Adobe Illustrator® is learning to master your work-
space. You'll be spending a lot of time here, so stay a while and get to know it.
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1: Artboard

Where you'll work on your graphic/document.

2: Tools Panel
Quick access to all available Tools. Can display in one column or two.

3: Panels
Complete options for specific aspects of your design, such as color, type, etc.

4: Control Panel
Some commonly used options for the specific Tool you have selected.

5: Application Menus
Additional commands, such as saving, adding effects, etc.



Navigating and Customizing Your Workspace

The first step to Taking Control of Adobe Illustrator® is learning to master your work-
space. You'll be spending a lot of time here, so stay a while and get to know it.

Color Color ( Swatches Gradie This is a Panel.
n,' Panels are crucial to doing work in Adobe
lllustrator®. If you mouse over the Panel
& : :

%i= m = icons, you can see what each one is

B B I E called. Click on each icon to open it. Click
W the double-arrow in the top-right to col-
[ THEER lapse the Panel.

The other icon in the top-right corner is
called a fly-out menu. The fly-out menu
has additional options beyond what you

can see in the main body of the Panel.
h. € [ H

More panels are available under the Window menu. m:f— :
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you can save it at Window > Workspace > New Workspace. e R
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Vector Drawing Basics

To draw your graphics in Adobe Illustrator®, you need to know the basic terminology
and mechanics of vector drawing.

The basic unit of any vector drawing is a path. There are several types of paths:

Open Path
The start point doesn’t meet the end point.
Can have Stroke applied, but not Fill.

Closed Path

The start point meets the end point.
Can have both Stroke and Fill applied.

Compound Path
Multiple paths combined together with a cutout.
Allows for letters to exist as single paths.

Paths are composed of individual anchor points connected together. There are
two types of anchor points:

NN N

Corner Point Smooth Point Anchor points have two
Path comes into point, Path gradually curves to sides and can combine a
stops, and goes out. point and out of point. smooth side and corner

side together. ;3



Vector Drawing Basics

To draw your graphics in Adobe lllustrator®, you need to know the basic terminology
and mechanics of vector drawing.

Smooth points create what is called a Bézier curve. Smooth points are controlled
through handles coming off the anchor point.

This is a handle.

\ There are two of them, one for each
side of the anchor point (in and out).

The direction of the handle controls
where the curve goes.

The size of the handle controls how

gradual the curve is (smaller = less
curve).

2 Pen Tool ®) This is the Pen Tool.

"'_p‘ Add Anchor Point Tool  (+)

. It's the most common way to draw
'p\ Delete Anchor Point Tool (-) Paths and control anchor points.

I\ Anchor Point Tool (Shift+C)

Click to create a corner point. Click and
drag to create smooth points.

Add or delete with Add Anchor Point

i , Tool or Delete Anchor Point Tool.
The Scissors Tool splits a path
4 into two paths by cutting along

, Anchor Point Tool changes smooth
two anchor points.

points to corner points, corner points to

smooth points, and adjusts handles on
A The Curvature Tool creates smooth points.

smooth points by default and
corner points with double-click.

Double-click points with the
Direct Selection Tool to select
angd adjust them.

=



Vector Drawing Basics

To draw your graphics in Adobe Illustrator®, you need to know the basic terminology
and mechanics of vector drawing.

= [T Rectangle Tool (M)
O Rounded Rectangle Tool

=/ Line Segment Tool (\)
/~ Arc Tool
“® Spiral Tool

O Ellipse Tool (L)
O Polygon Tool
% Star Tool

., ]
(®) Flare Tool

EE Rectangular Grid Tool
@ Polar Grid Tool

Many drawings are made of simple geometric shapes, which can be drawn with
the line and basic shape tools (pictured above). Select the tool, then either click
and drag to create the shape or single-click to pull up a dialogue box.

Hold down Shift to size in proption. Rectangle

width: X
20
Height:

Cancel OK

| Ues=e Tyupn Text into Vector Shapes

Font > : '

| To manipulate letters, you'll need to turn your
Recent Fonts > .
Size ( text into vector shapes that can be altered

exactly like any other path. Right-click the text

Create Outlines and select Create Outlines.
Transform >
Arrange >

| Select >




Taking Control of Objects on the Artboard

So, you've got some stuff on your Artboard, but what do you do with it now?

Selection and Direct Selection

These are the basic Tools you'll use to select objects.
Direct Selection is used for objects in a Group or anchor points in a path.

Placing
Bring in new objects (images, SVG files, etc.) through File> Place.

Grouping
Combine multiple objects together with Object > Group. Grouped objects move
together and act as a single object for most commands.

Locking
Lock an object to the Artboard and prevent it from moving with Object > Lock >
Selection. Unlock all objects with Object > Unlock All.

Expanding
Divide a single object into multiple objects that work together to create the
appearance of that object with Object > Expand.

Arranging

Send objects forward or backward within their Layer through Object > Arrange.

Layers Graphic Sty Artboards This is the Layers PanEI.

O . Layer 2

While Object > Arrange is useful, there
will be many times when your artwork
in complicated enough that you need to
use Layers.

Layers are basically different levels of a
document. Put similar content on
Layers and you can arrange how they
display in the stack, as well as toggle
them on and off and select all objects
on a Layer.




Taking Control of Objects on the Artboard

So, you've got some stuff on your Artboard, but what do you do with it now?

¢ Align

Align Objects:
= & &S

Distribute Objects:

- 4.
T S s

Distribute Spacing:

i~

Pathfinder

Shape Modes:
|.|:_"| F
Pathfinders:

W 4 N

Align To:

The Transform Panel

Allows you to precisely place and size
objects on the Artboard. The chain icon
on the right side toggles whether the
object sizes in proportion or not. The
grid on the left side control where on
the object the X and Y values are.

The Align Panel

Allows you to align objects to each other
or to the Artboard, as well as distribute
objects and the space between them.

The “Align To” box in the bottom-right
controls whether the item(s) align to
each other or the Artboard.

The Pathfinder Panel

Allows you to combine objects together
into compound paths. Unite combines
overlapping paths into a single path.
Minus Front creates a cutout from the
object in front. Other commands
include Intersect, Exclude, Divide, Trim,
Merge, Crop, Outline, and Minus Back.

] Scale Tool (S)
ﬁ' Shear Tool

Rotating, reflecting, etc. can be

> done through the Transform
panel, but double-clicking the
tools in the Tools Panel gives you
more options for each.

= ) Rotate Tool (R)

“\ Reshape Tool 5i¢ Reflect Tool (O)

7



Other Essential Tools and Panels

Here’s a quick look at some essential tools and panels and what they can do.

= T Type Tool
¥ Area Type Tool

~¢ Type on a Path Tool

Blend Options
Spacing: | Smooth Color v

Orientation: prithy it

Cancel

= [jI§ Column Graph Tool 1)
42! Stacked Column Graph Tool
E. Bar Graph Tool

T oooo00 |

¢ Stroke

Weight: : _ v

= Dashed Line

Type Tools

Create simple text boxes, text boxes with
unique shapes, or make your text conform
to the shape of any path.

Blend Tool

Blend shapes and colors together. Used to
create patterns, long drop shadows, etc.

Graph Tools

Create graphs and input your data. Graphs
act just like any other object and can be
styled however you want.

Color Panels

There are three main color panels: Color,
Swatches, and Gradient. Color lets you
change individual colors. Swatches lets you
save and access saved colors. Gradient lets
you create and edit gradients.

Stroke and Brushes Panels

These control your object’s stroke. The
Stroke Panel lets you change the weight of
the stroke, as well as control caps, dashing,
and arrowheads. The Brushes Panel lets you
add texture to your strokes with premade
brushes. You can also create your own or
import brush libraries for all kinds of effects.



Other Essential Tools and Panels

Here’s a quick look at some essential tools and panels and what they can do.

Layers Graphic Styl Artboards = Artboards and Graphic Styles

1 Anboard 1 o These panels allow you to create new Art-

23 Do Feony L boards and edit your existing ones, as well
as create graphic styles that can quickly and
easily be applied to other objects.

2 Artboards

SECCUEERES  Transparency and Appearance
Normal v Opacity: > Two of the most powerful panels in Adobe
YRRy lllustrator®. Transparency allows you to
O create transparent objects, and Appearance
L | is used for creating multiple strokes/fills and
editing any aspect of an object’s appear-
ance.

SCharacter Pai Ch Pai Gly Tal [ | -= Type Panels

Touch Type Tool These panels give you everything you need
AT = to handle your typography. Character and

. Paragraph Panels handle short and long
text, respectively, while Glyphs handles spe-
cial characters. Character and Paragraph
Styles, like Graphic Styles, lets you save a set
of typography settings and apply it to any
5 text accordingly.

English: USA dg  Sharp




Advanced Tricks to Try

Once you've got everything else down, it’s time to explore some of the more advanced

things that Adobe Illustrator® can do.

o
x

Image Trace

Preset: [Default]

View: Tracing Result

Mode: Black and White

Threshold:
Less

p Advanced

Paths: 918
Anchors: 4377

v Preview
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Image Trace

Create vector objects out of raster (non-vec-
tor) objects. Go to Object > Image Trace >
Make, and adjust the settings by clicking the
Image Trace Settings box in the Control
Panel. Can be used to create vector silhou-
ettes, paintings, line art, etc.

Live Paint

Compound paths can be tricky to fill. Take
this donut. Applyng a fill only fills the main
part, but not the center, since it's not consid-
ered part of the path. The Live Paint Bucket
Tool lets you fill in all parts of a path, even if
there are gaps in the path. Go to Object >
Live Paint > Make, then select the Live Paint
Bucket Tool to get started.

Envelope Distort

You can warp/distort objects with the Effects
menu, but Object > Envelope Distort > Make
with Mesh allows you precise control over
any kind of warping/distortion.



Advanced Tricks to Try

Once you've got everything else down, it’s time to explore some of the more advanced
things that Adobe Illustrator® can do.

Gradient Mesh

Creating a Gradient Mesh allows you to
customize your own gradient pattern with
colors shifting across a grid. Go to Object >
Create Gradient Mesh, then use Direct Selec-
tion to select individual points on the grid
and assign colors.

View Window Help Effects
Apply Last Effect O%E The Effects menu is divided into two sec-
e s tions: lllustrator Effects and Photoshop
Document Raster Effects Settings... Effects. The former is all-vector effects and
llustrator Effects the latter is raster effects.
3D | 2
Convert to Shape > Some useful effectsto try include 3D, Distort
Crop Marks and Transform > Roughen, Path > Offset
Distort & Transform > .
Path > Path, Stylize, and Warp.
Pathfinder >
Rasterize... |
Stylize >
SVG Filters >
Warp >

Effect Gallery...
Artistic

Blur

Brush Strokes
Distort

Pixelate

Sketch

Stylize

Texture

Video

VVYVYVYVYVYYVYYY
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The material appearing in this website is for informational purposes only and is not legal advice.
Transmission of this information is not intended to create, and receipt does not constitute, an
attorney-client relationship. The information provided herein is intended only as general information
which may or may not reflect the most current developments. Although these materials may be
prepared by professionals, they should not be used as a substitute for professional services. If legal or
other professional advice is required, the services of a professional should be sought.

The opinions or viewpoints expressed herein do not necessarily reflect those of Lorman Education
Services. All materials and content were prepared by persons and/or entities other than Lorman
Education Services, and said other persons and/or entities are solely responsible for their content.

Any links to other websites are not intended to be referrals or endorsements of these sites. The links

provided are maintained by the respective organizations, and they are solely responsible for the
content of their own sites.
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