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WHAT-IF FEATURES 
Goal Seek 

Excel’s Goal Seek feature allows you to work “backward” in re-calculating the result of formu-
las. Instead of trying to rework the formula (such as you might in an algebra problem when you 
attempt to solve for Y instead of X) Excel simply substitutes a series of values in one of the orig-
inal formulas until it reaches the answer you want.  
 

Goal Seek with the PMT function 

Suppose you just used the PMT function to figure out the monthly payment on a car loan. After 
seeing the result, you feel as if you could comfortably pay more per month. Instead of rework-
ing the function numbers many times to come up with the amount that you want to be the 
monthly payment, use the Goal Seek com-
mand to find the answer immediately. 
Imagine the following entries where the func-
tion in B1 calculates the monthly payment re-
quired to pay off a 4-year loan of $20,000 at 
4% interest.  
 
1. Select  the cell containing the result you want to change (e.g. cell B1 above) 
2. Click The What-If Analysis button in the  Data Tools group of the Data tab 
3. Select  Goal Seek 
4. Type the result you want to see in the panel to the right of: To value: 
5 Click in the panel to the right of: By changing cell: 
6. Select  the cell in the worksheet whose value you want to change (in the example 

above you could choose A3 to allow a higher principal, A2 to allow a different 
term, or A1 to allow a different rate. 

 
In the example to the left, 
Goal Seek is ready to calcu-
late a monthly payment of 
$500 in cell B1 by changing 
the principal in cell A3. 

   
7. Click OK 
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At this point, the Goal Seek Status dialog box (see below) will indicate that a solution has 
been found; the solution will be displayed on the worksheet, but you may need to re-position 
the dialog box to see the answer. 

 
 
Sometimes, the dialog box will indicate that Goal Seek may not have found a solution - click 
Cancel and try different entries. 
 
8. Click OK to change the worksheet to include the goal and the altered cell. 
 or  
 Click Cancel to leave the worksheet unchanged. 

 

Another situation appropriate for Goal Seek is when a series of test scores are being averaged 
and you need to know what the next score in the ongoing series needs to be to reach a desired 
average. 
 

PMT 

Use the function PMT to calculate the monthly payment on a car or house loan. 
 

PMT has the form:  =PMT(Rate, NPER, PV) 
 

Where: 

Rate Is the interest rate, expressed, for example, as 4.5%/12 to indicate the monthly rate 
on a 4.5% annual rate 

NPER Is the number of periods required to pay off the loan, say 4 years (48 months) for a 
car, 30 or 15 years (360 or 180 months) for a house. You can enter data as 360 or 
30*12 to refer to a 30-year house loan 

PV Refers to Present Value – the amount you are borrowing 
 

If used in the above manner, PMT returns the monthly payment (principal and interest 
included) 
 

What is the monthly payment on a 4-year car loan of $25,000 at 4% annual interest? 
 

=PMT(4%/12,48,20000) returns the amount -$564.48 
 

To make the result of the PMT function positive, precede the PV argument with a minus sign.   
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SOLVER 
 

If you want to have the result of a formula be a specific value, you can often rely on Excel's Goal 
Seek feature, which re-sets the value of another cell to an amount that adjusts a target cell.  
But if you'd like to set a target cell to a specific value while allowing changes to more than one 
cell (and at the same time keep their values within upper and lower limits), you need to use Ex-
cel's Solver utility.  
To use Solver, you must first make sure that it is activated. You need only do this one time; 
thereafter, you can access Solver on the Data tab in the ribbon. 
To activate Solver: 
1. Click The File tab in the Ribbon 
2. Click  Options 
3. Click Add-Ins 
4. Click Solver Add-in 
5. Click The drop arrow in the box next to Manage and click Excel Add-ins 
6. Click Go 
7. Check The box next to Solver Add-in and click OK 

 
 

To use Solver to recalculate a target value: 
1. Select A target cell that contains a formula 
2. Click Solver in the Analysis group on the Data tab 
3. Click one of the radio buttons next to Max, Min, or Value of 
4. Enter A value in the panel next to Value of 



Excel – What-If Features 

 

Copyright © 2013 Dennis Taylor  Page 4 of 13 
303/440-1380 dennistaylor@msn.com 

 
6. Enter A range of one or more cells in the panel next to By Changing Cells 
7. Click Add 
8. Select  Cell References and type or select a cell reference;  

 select an operator; type a constraint in the Constraint panel. 
9. Click  Add 

Repeat Steps 8 and 9 
as many times as de-
sired to list all con-
straints. Click OK 

 
10. Click Solve 
When Solver finds a solution, it displays the changed worksheet and the Solver Results dialog 
box. 



Excel – What-If Features 

 

Copyright © 2013 Dennis Taylor  Page 5 of 13 
303/440-1380 dennistaylor@msn.com 

 

11. Select Keep Solver Solution or Restore Original Values 
12. Click Save Scenario, if desired. 
13. Click OK 

Note: When Solv-
er cannot find a 
result based on 
your constraints, it 
displays this dialog 
box. 
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Scenario Manager 

Scenario Manager allows you to save the layout and conditions (including different cell con-
tents) of different scenarios that you create.  
 
For example, you may want to have a spreadsheet model based on an optimistic set of sales 
figures for each of four quarters. You may also want to have two other scenarios, one using 
numbers based on low sales figures, another based on an average set. You would like to be able 
to activate any of these scenarios quickly rather than altering cell content each time you want-
ed to see a particular view. 
Caution: if you want to be able to activate different scenarios and yet return to the state of 
your worksheet before you activated any of them, you should first set up a scenario with the 
values you want to return to. 
 
Creating a Scenario 
1. Click The What-If Analysis button in the  Data Tools group of the Data tab 
2. Click Scenarios 
3. Type A name for the scenario in the panel next to Scenario Name 
4. Enter An address of one or more cells where you want to set certain values. 
5. Click OK 
In the Add Scenario dia-
log box, you create a 
scenario name and 
identify cells to be as-
signed values. 

 
   
6. Select The specific values to enter into each of the cells you selected in Step 4. 
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In the Scenario Values dialog box, 
enter desired values. 

 

7. Click OK 

 

8. Click the Show button to 
display a scenario. 
 
In the image to the 
right, the Show 
button has been 
clicked to reveal 
the High Sales  
Scenario  

 
9. 

or 
Click 

 
the Close button to return to the worksheet without switching to a different sce-
nario. 
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Scenario Summary 

 
When you have multiple summaries defined, it may be of value to see the details of the various 
scenarios summarized on a separate worksheet.  
 
Creating a Scenario Summary 

 

1. Click The What-If Analysis button 
in the  Data Tools group of 
the Data tab 

2. Click Scenarios 
3. Click The Summary button 

 
4. Click OK 
   

 
The Scenario Summary (on a new worksheet named Scenario Summary) shows all values of 
changing cells for various scenarios in the current workbook. 
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Data Tables 

Data Tables allow you to set up tables containing variable in rows and columns with a master 
formula. They come in two forms – those with one variable and those with two variables.  
 

A good example of a Data Table is one in which you want to evaluate varying terms and interest 
rates on a house or auto loan. 
 

Data Table formulas refer to empty cells. These empty cells are then referenced as Input Cells 
(one for row entries, the other for column entries) when you activate the Data Table command. 
 

To set up a two-variable Data Table to calculate monthly payments on a car loan 

1. Enter A series of interest rates in a column or row  
2. Enter  A series of terms (36 mo, 48 mo, etc.) perpendicular to the column or row 

where you entered the interest rates. 
  

 
3. Type  The master function or formula at the intersection of the column and row.  

For the Row entries (Row 2 above) refer to a nearby empty cell, such as C1. 
For the Column entries (Column B above) refer to a nearby empty cell, such as 
A2. 

In the example above, click in cell B2 and type =PMT(A3/12,C1,-A1) 
Cell C1 serves as the Row Input cell 
Cell A3 serves as the Column Input cell 
Cell A1 contains the principal – the amount borrowed 
Note: the formula may result in an error or a blank 

4. Select The rectangular range that includes the master formula and all of the variables 
– B2:E15 below 

5. Click The Data menu 
6. Click Table 
7. Enter  A value for the Row Input Cell – C1 below 
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8. Enter  A value for the Column Input Cell – A3 below 
  

 
9. Click OK to see the results as shown below 
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Using the IF function & relational operators  

 
The IF function provides alternate answers, depending upon the results of a condition. 
 
      The generic form of the function is:  =IF(condition,true,false) 
 
In the simplest form of this function, there are three arguments:  
  
1. A condition to be tested 
2. The result if the tested condition is true 
3. The result if the tested condition is false 

 
The condition is a logical expression, indicating some kind of comparison.  
Comparisons between the following kinds of data are possible: 
 
 Comparison Type Example 
 Cells and values  B2>10 
 Cells and formulas B2<(C3*7) 
 Cells and functions B2=SUM(P2:P6) 
 Cells and text strings B2="Sell " 
 Formulas and Values B2/6>=100 
 Functions and Values SUM(H6:H12)<50 
 Functions and formulas AVERAGE(G3:H8)>(Q6*R5) 

 
The true or false portions of the statement can be values, cell locations, formulas, functions, or any 
combination of these types of entries; the true or false result might also be a text string enclosed in 
quotes. 
 
Type IF functions in the worksheet cells where you want the results to appear. 
 
Relational Operators 

Use these relational operators in building an IF statement condition: 
 
= Equal to  
> Greater than  
<  Less than 
>= Greater than or equal to  
<= Less than or equal to  
<> Not equal to 

 
Examples: 
=IF(A2<=9,10%,20%)     or      =IF(A2<=9,.1,.2)      
If A2 is less than or equal to 9, the result is 10%, otherwise, the result is 20% 
  
=IF(A2>100,150,75%) 

When using operators consisting of two symbols, (such as 
>= or <>) you must use the symbols in the same left to 
right order as seen in the list shown to the left. 

i.e. use  B2>=7 
 not  B2=>7 
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If A2 is greater than 100, the result is 150 otherwise, it is 75% 
=IF(A2>10,B3*2,B6*2) 
If A2 greater than 10, result is B3*2, otherwise, it is B6*2 
Note: this function does not alter cells B3 or B6 
  
=IF(A2=10,10%,20%)*B4 
If A2 is equal to 10, the result is 10%*B4, otherwise, the result is 20%*B4 
Note: this function does not alter the content of cell B4 
=IF(A2<>1, "Match", "Fail") 
If A2 is not equal to 1, the result is the text string Match, otherwise, the result is the text string Fail 

Notice that when you use text strings (like the words Match and Fail above), they must be embed-
ded in double quotes.  

If you want one of the results in an IF statement to appear blank, use the double quotes twice, 
with no space between them;     ""    This is referred to as a null string.  

 

Logical Functions and the IF function 

 
You can use logical functions (actually functions in their own right) nested in IF functions: 
 
=AND Check to see if all of two or more conditions are true: 

 
AND(A4="B",B7>10) 
AND(J7=1,K3=5,M3>0) 

 The conditions are true only if all arguments are true. 
  
=OR Check to see if any of two or more conditions are true: 

 

OR(B3="Q",B4= 6) 
OR(J7>5,K3>5,L3>5) 
 

 The condition is true when any of the arguments is true. 
  
=NOT Used to negate a condition; the result is true when the condition is false. Use this 

operator carefully to avoid unwieldy or unclear construction. 
 NOT(J7>B5) 

 
Examples: =IF(OR(A3=7,D3=5)), 100, 50) 
 If A3 equals 7 or D3 equals 5, the result is 100, otherwise the result is 50 
  
 =IF(AND(B6= "A", B7 = "B"), 100, 50) 
 If B6 equals A and B7 equals B, the result is 100, otherwise the result is 50 
  
You can use AND and OR in the same IF statement, but it may be difficult to write and test the 
statement. Can another person figure out what you have written?  
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=IF(OR(A3=7,AND(B3=5,D3=5)),"Bonus", "Nothing") 
If A3 equals 7 or both B3 and D3 equal 5, the result is the string Bonus, otherwise the result is the 
string Nothing). 
  
=IF(AND(A3=7,OR(B3=5,D3=5)),"Bonus", "Nothing") 
If A3 equals 7 and either B3 or D3 equals 5, the result is the string Bonus, otherwise the result is the 
string Nothing). 

 

Nested IF Statements 

You sometimes need to have more than two possible results in an IF statement. You can do this 
by making either the true or the false result itself be another IF statement.  
 
 =IF(condition1,true,if(condition2,true,false)) 

 =IF(condition1,if(condition2,true,false),false) 

 
When you attempt to handle more than three results in an IF statement, it may be more efficient to use 
the VLOOKUP, or CHOOSE function, as explained in the next sections. 
 
Examples: 
=IF(B3>7,"HIGH",IF(B3>4,"MIDDLE","LOW")) 
If B3 is greater than 7, the result is the string HIGH,  
if B3 is greater than 4 (but less than or equal to 7) the result is MIDDLE, 
otherwise the result is LOW. 
  
=IF(D4>=40000,30%,IF(D4>=25000,20%,10%) 
If D4 is greater than or equal to 40000, then the result is 30%;  
if D4 is greater than or equal to 25000 (but less than 40000) the result is 20%, otherwise the 
result is 10%. 

 
Observe these general guidelines that apply to the IF function as well as to other functions: 
 Spaces may follow commas or equal signs 

 Type any characters you want between the set of double quotes in text strings. 

 Capitalization of function names and cell references is not required. 

 A closing paren  )   is not required when there is a single set of parentheses and a closing paren 
would terminate the function.  For example, when you type: 

    =IF(A1>100,1,2     or         =AVERAGE(D3:D12 

and press enter, the functions will be entered correctly. 

 When multiple sets of parentheses are used, you must type all open and close parentheses. 
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